Back to overview
Downtime

Elotech website, Elotech hosting platform, Elotech support, and 1 other service are down

Aug 25 at 09:22am CEST
Affected services
Elotech website
Elotech hosting platform
Elotech support

Resolved
Aug 25 at 09:45am CEST

Elotech hosting platform recovered.

Updated
Aug 25 at 09:44am CEST

Elotech website recovered.

Updated
Aug 25 at 09:42am CEST

Elotech support recovered.

Created
Aug 25 at 09:22am CEST

Elotech website, Elotech hosting platform, and Elotech support went down.